Apr 08

Access points having a hard time downloading 7.0.250.0 code

Cisco recently released Software version 7.0.250.0 for their Wireless LAN Controllers (WLC). This version of code is a bug fix version. Over the past couple of weeks I have had the opportunity to upgrade some 2106 and 4404 WLCs to version 7.0.250.0

Upgrading a Cisco 2106 to 7.0.250.0

I have a large number of Cisco 2106 WLCs. If you are not familiar with the 2106, it is a small controller that can only handle a hand full of access points. It has a switch on the back with two of the ports providing PoE. Most of my controller have three access points directly connected to the controller.

Most of the upgrades that I have performed to 7.0.250.0 have gone very well. I have had a few of them where the APs (1131) do not come back online. Some of these are due to the AP failing and they need replaced. Others I have found them in the downloading state, then never getting out of that state.


To fix this, I have reverted back to the old version. Once the controller is back on the old version, the APs have always come back online for me. I then shut down the ports going to the APs, then download 7.0.250.0 again and perform the upgrade a 2nd time. After the 2106 is on 7.0.250.0, then I enable the ports to the APs. The APs have been able to come up, download the new software and register. I have noticed this takes longer then normal. Normally all of the APs are up after 11 minutes, these seemed to take about 15-20 minutes for some reason.

Upgrading a Cisco 4404 to 7.0.250.0

I have had the opportunity to upgrade some 4404 controllers from an earlier version of 7.0.x.x to 7.0.250.0. I used TFTP from my laptop on the same LAN as the 4404 to get the file there. In the past, I have had the WLC crash and reload when transferring the image via FTP or TFTP over the WAN. It may be painful, but I suggest you always transfer the image from the LAN instead of the WAN for 4404s.

I did a predownload of the image to the access points (AP). The 4404 will only transfer the image to 10 APs at a time. In the morning, I transferred the image to the controller, then issued the predownload command. By the time I did the upgrade in the evening, the predownload was done. I did have about 10% of the APs that didn’t take the predownload and had the image transferred after the WLC rebooted.

Overall, the upgrade went very smooth!! So far, this upgrade is on par with all of the other upgrades that I have done with Cisco’s WLCs.

How has your WLC upgrades gone?
Did everything work well afterwards?